
How to Use DailyDeeds ver. 1.1
by Leo Wierzbowski, 1/20/90

What DailyDeeds Is

DailyDeeds is an application you use to track and report what you do with your 
time on the job.  It is intended for hard working folks who have many 
different tasks during their workday, and like to produce a periodic 
accounting of how much time is spent on each of their tasks.

Some folks are required to give such an accounting, others do it for personal time
management.  I'm required to keep a timelog of all that I do on the job, and 
once per year produce a report of how much time I've spent on each task 
during the year.  I wrote this program to make it easy for me to keep track of
my time and tasks and produce that report.  

I've since discovered that producing such reports at different time intervals not 
only keeps my supervisor up-to-date on what I am doing, but also can be 
used for proving my value to my employer.  I also use DailyDeeds for a quick
check on how many hours I've worked during a pay period (I'm on a 
timecard and I'm not allowed to work more than 40 hrs/workweek).  With 
just a couple of clicks of the mouse, I can see if I must leave work early on 
the last day of the workweek.

DailyDeeds is no-warranty as-is freeware.  You can copy it freely and give it to 
anyone anywhere.  

The Files on Your Disk

Your disk should have two files -- the DailyDeeds application and the “How to Use 
DailyDeeds” manual (in MacWrite II format):

DailyDeeds creates and maintains two kinds of files on your disk -- the timelog file
and its corresponding deeds menu file:

Both the timelog file and it’s menu file must be kept together in the same folder 
on your disk.  Double-clicking on the timelog file will cause DailyDeeds to 
startup and open both the timelog and menu files.  Double-clicking on the 
menu file will cause DailyDeeds to open a new empty timelog, but with the 
deeds menu already filled (this makes it easy to create new timelog files 
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without having to manually recreate the deeds menu).

Starting DailyDeeds the first time

You should use a copy of DailyDeeds, not your original.  Copy DailyDeeds on the 
diskette or in the folder you wish to keep it and your timelog file.

Double-click on the DailyDeeds icon and wait a second for it to display the 
"About..." box.  Click the mouse once (or do nothing for 5 seconds), then 
you'll see:

This is normally where you would open an existing timelog “deeds menu” file in 
order to create a new, empty timelog file with an existing set of deeds to 
choose from (more about this later).  Or, if you had an existing timelog file, 
you could just double-click on it from the desktop and the Mac would start 
DailyDeeds and open the timelog.  Since you're starting a new empty 
timelog file with a new empty deeds menu, click the "Cancel" button with 
the mouse.  Next you'll see one day's log:
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Entering Your Deeds into the Log

Entering Deeds into the Menu

Before you can enter deeds into the log, you must add some deeds into the 
"Deeds" pull-down menu.  You do this by selecting "Add Deed to Menu" in 
the "Edit" menu:

Once "Add Deeds" has been selected you'll see this:
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All you need to do is type a deed (task) and press return (or click OK).  Simply 
repeat this process until you have a workable set of deeds in the "Deeds" 
menu.  Don't worry, you can add some more at any time.  Here is what the 
"Deeds" menu will look like after you've added a few items in it:

You can add a previously deleted deed without fear of duplication.  A few 
characters have special meanings in menus (   ; ^ ! < / (   ), so any of them 
you enter will be automatically replaced by a period.

Entering Deeds into the Log

Simply select a deed in the "Deeds" menu and then click the box representing the
appropriate 15 minute time period with the mouse.

If you wish to repeat the entry of the selected deed, you can click several boxes 
with the mouse.  You can press the "Return" or "Enter" key repeatedly to 
enter the selected deed in several adjoining boxes.  You can use the "Tab" 
key to skip over boxes.  I like to use the mouse for selecting a deed and the 
enter key for entering that deed, but you can use whatever method appeals 
to you the most.

The Date of the log can be edited like normal text (by selecting the characters 
you want to change and then typing), but you must enter a date in the 
MM/DD/YYYY format (e.g., June 10 1952 is entered as 6/10/1952).  When you
change the date on a log, DailyDeeds repositions the log in your logfile 
according to date order.

You can view and edit other day's logs with the "Backward" and "Forward" 
buttons at the bottom of the log.  The "Clear Changes" button clears 
changes you've made to the displayed day’s log since you’ve either looked 
at another day’s log or saved the file to disk.
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When you're done entering deeds into the log, you select "Quit" in the "File" 
menu and then confirm whether or not you want to save the changes you 
made to the logfile.  

If your log is named "Untitled", you will be prompted to enter a real name for your
logfile to save it on a disk.  Two files will be saved -- your timelog file and 
your timelog’s menu file.  

Editing Deeds in the Menu

Should you wish to change one of the deeds in the "Deeds" pull-down menu, you 
merely select a deed in the "Deeds" pull-down menu,

 then select "Edit Checked Deed" in the "Edit" pull-down menu.  
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You will see the dialogue below, where you may change the deed to whatever you
like.  A few characters have special meanings in menus (   ; ^ ! < / (   ), so 
any of them you enter will be automatically replaced by a period.

When you change a deed in the menu, your log will display that change as well.  
If you change a deed to one that you previously deleted, your log will not 
change (otherwise your log might become incorrect).

Deleting Deeds in the Menu

If your "Deeds" pull-down menu is looking cluttered with deeds you don't need 
anymore (or if you’re trying to put more than 31 deeds in the menu), you 
can delete some.  Deleting a deed from the menu will not delete it from your
log.  This way, you can keep a short "Deeds" menu and still produce reports 
on everything you've ever done (your log’s menu file can hold up to 360 
deeds).

To delete a deed from the "Deeds" pull-down menu, select the deed you want to 
delete (in the menu), then select "Delete Checked Deed" in the "Edit" menu.
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You'll be asked to confirm your command to delete that deed:

Once you've deleted the deed from the menu, your log will display that deed with
an asterisk prefixed.  This tells you that this deed has been deleted and that 
DailyDeeds will remember it for your reports.

Changing the Log File’s Hours
The 8 a.m. through 5 p.m. hour titles are the default.  You can change these by 

selecting “Change Row Hours” under the “Options” menu:

Then just enter the starting hour for the hour titles (1 thru 11 = a.m. hours, 12 
thru 23 = p.m. hours, 24 = midnight).
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Automatic File Backups

At your option, you can have your timelog file and its menu file backed-up every 
time you save changes (just in case you goof and then save it to disk).  Just 
select “Auto File Backup” under the “Options” menu:

When the “Auto File Backup” option is turned on, you can see a checkmark next 
to it:

What “Auto File Backup” really does is rename the previous version of your 
timelog and menu files to “Backup” + the name they had, just before 
DailyDeeds saves your timelog and menu files to disk.

Creating and Deleting Daily Logs

When you start DailyDeeds for the first time, you are given one day's log to fill in.
If you want to fill in more logs (for more days), then you need to get a new 
empty log.
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If you select "New empty log" in the "Log" menu, you'll get an empty log for 
today's date.  You can edit the date to whatever you like (DailyDeeds keeps 
your logs in date order).  Be sure you enter the date in the MM/DD/YYYY 
format.  You can then enter deeds into the log.

If you want to delete the day's log that is displayed on the screen, select "Delete 
This Log" in the "Log" menu.  

Next, click on the “OK” button to confirm deleting that day’s log:

Finding a Daily Log

Let's say your log file has 100 daily logs in it, and you need to look back at the log
for one particular date.  Select "Lookup Date" under the "Log" menu:
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and then enter the log's date.

Displaying the Log in the Middle Quickly

Say your file has 200 logs in it and you want to look at the log in the middle and 
you don’t want to click on the “Backward” button for 30 minutes.  Just select
“Go To” under the “Log” menu:

Then enter the number (not date) of the log you want to see (each log displays its
number in the upper right-hand corner).  You don’t have to enter leading 
zeroes:
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Producing Reports of Your Daily Deeds

You can produce reports of your activities over a given date range.  Your reports 
can be output to a printer, a disk file, or the screen.  No matter what output 
device you want for your report, you'll select "Print Report" in the "File" pull-
down menu.

Next you'll see the following dialogue, which wants you to enter the starting and 
ending dates for the report (the earliest and latest dates in your logfile 
appear by default).  You also must click the button next to the output device 
that you want for your report (if the button is not already filled in).  Click OK 
when you're ready.
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What you see next depends on which output device you selected.

If You Selected "Printer"

You'll see the standard printer dialogue box to confirm your command:

Click OK and let your report print.

If You Selected "Disk"

You'll see the standard file dialogue for you to enter a file name for your report 
and confirm your command:
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The disk file will have a tab character separating the columns in the report.  This 
is so you can use the tab on the ruler in your word processor to position the 
columns exactly where you want them.

If You Selected "Screen"

A scrollable window will open on the screen and (after a brief wait) will contain 
your report.  

If you wish, you can select lines of the report and "Copy" them to the clipboard 
for pasting into another application's document.  The clipboard will have 
spaces separating the columns in the report.

Exporting Your Logs to Another Application

Perhaps one day you will find another program that can analyze your timelog in a 
great way, giving you the ultimate insight into the way you utilize your time.
You can "export" your DailyDeeds log to a file that most Macintosh database 
and statistical programs can read.  To do this, just select "Export As" in the 
"File" menu.  Next, give the file a name and confirm your command:
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The exported file will be a TEXT file.  The file will have one line (record) per day 
with a tab character between the date and deeds.  Each deed in a line 
represents one fifteen minute time period.

Quitting DailyDeeds

To quit DailyDeeds, select "Quit" in the "File" menu.  

If you've made any changes to your log since you started DailyDeeds, you'll be 
asked if you want to save those changes (normally you will want to save 
changes to your log).
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DailyDeeds under MultiFinder

DailyDeeds uses 160K RAM under MultiFinder.  Most MultiFinder users will be able 
to leave DailyDeeds open while they use other applications.  Although 
DailyDeeds does not support the fancier features of MultiFinder (like 
background processing, etc.), it works fine.  You can switch between 
DailyDeeds and other applications under MultiFinder with no problems.

DailyDeeds Limits and Requirements

It allows up to 360 daily logs in one timelog file.  Up to 360 deeds can be stored in
a timlog file’s menu file.  Up to 31 deeds can appear in the “Deeds” menu.

Both the timelog file and its menu file must be in the same folder on a disk.  They
don’t need to be in the same folder as DailyDeeds.

This version of DailyDeeds requires a Mac Plus or better running System 4.1 or 
later.

DailyDeeds Legal Matters

I make no warranties, express or implied, that DailyDeeds is free of error, or is 
consistent with any particular standard of merchantability, or that it will 
meet your requirements for any particular application.  It should not be 
relied on when an incorrect timelog or report could result in injury to a 
person or loss of property.  If you do use DailyDeeds in such a manner, it is 
at your own risk.  I disclaim all liability for direct or consequential damages 
resulting from your use of this program.  

Changes Since Version 1.04c

Deeds for a log file are in a separate menu file
deeds menu file’s name = log file’s name + “Menu”
(to use the same deeds menu for a new empty log file
just open the old menu file from the Finder or close your logfile,
select “New” under the “File” menu, then open the menu file)

Deeds are sorted alphabetically in deeds menu
after opening a log file, or adding/deleting a deed from menu
(editing a deed does not resort the menu)

Log file can be opened and closed
“Go To” command added to Log menu
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Hours titles can be changed
Automatically converts old format log to new format log

old format log file remains untouched
new format log files have default names = “New” + old name

Optionally makes backups of log and menu files during save
backup files’ names = “Backup” + files’ names

Correctly reports any date not found errors
Correctly handles two logs with the same date
Keyboard equivalents to most menu commands
New deed added to menu is automatically selected
Confirmation dialog added to Delete This Log command
Changed text of some dialogs, buttons, and menu commands

Address

InterNet: Leo@PINE.CIRCA.UFL.EDU
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